Page tree
Skip to end of metadata
Go to start of metadata

Contents of this Guide

Introduction

Opal is an application that runs on a server. Users access Opal via the web or on client workstations via a secure shell connection over a network.

This guide is for whoever will set up Opal--typically, a system administrator.

The guide covers hardware and software requirements and includes procedures for deploying Opal on a server and setting up the client workstations.

When requirements are met, administrators can follow:

  1. the Opal Installation Guide,
  2. the R Server Installation Guide,
  3. and the Opal Configuration Guide.

Opal package is available in different format:

TypePackage Repository
Debian
RPM
Zip
Docker

Requirements

Hardware Requirements

Server Hardware Requirements

Component

Requirement

CPU

Recent server-grade or high-end consumer-grade processor

Memory (RAM)

Minimum: 4 GB
Recommended: >8 GB

Disk space

Minimum: 160 GB
Rule of thumb calculation: 10 GB for operating system + 4 GB/10000 participants

Client Hardware Requirements

Component

Requirement

CPU

Low-end consumer-grade processor

Software Requirements

Server Software Requirements

You must install the following software on the Opal.

Software

Suggested Version

Download Link

Use

Installation/Configuration

Java

>= Java 8.x

http://www.oracle.com/technetwork/java/javase/downloads/index.html

Java runtime environment - needed to run Opal

Java 8 Installation Guide

Java 8 Ubuntu Installation Guide

MySQL

>= 5.5.x

http://www.mysql.com/downloads/mysql/

Database management system - stores data imported into Opal

MySQL Database Administration

MongoDB>= 2.6.xhttp://www.mongodb.org/downloadsDatabase management system - stores data imported into OpalMongoDB Database Administration 
R>= 3.0.xhttp://cran.r-project.orgStatistical analysis engineR Server Installation Guide

At least one database management system must be installed. It can be MongoDB, MySQL or both.

MySQL, MongDB and R can be installed on a server machine different from Opal server.

 

Client Software Requirements

  • To access Opal via the web you must have a recent web browser such as Firefox 3.6 or Chrome 8.0, Internet Explorer 9.0.
  • To access Opal via SFTP use any graphical clients such as FileZilla or the Firefox add-on FireFTP.
  • No labels